Back to overview
Degraded

Virtual Asset Dispatch

Apr 10, 2026 at 9:22am UTC
Affected services
Production
api.trlyr.com/virtual-assets
api.trlyr.com/physical-assets

Resolved
Apr 10, 2026 at 9:53am UTC

The connectivity issues have been resolved, and asset dispatch functionality is now fully restored. We are continuing to monitor the system closely to ensure stability. Thank you for your patience.

Updated
Apr 10, 2026 at 9:47am UTC

Our IoT provider has acknowledged the issue and is currently investigating the cause of the timeouts. We are monitoring their progress closely—please stand by for further information.

Created
Apr 10, 2026 at 9:22am UTC

We are currently investigating 503 errors occurring during asset dispatch, triggered by connection timeouts from our IoT service provider. This issue is causing some physical assets to be temporarily unresponsive. Our team is actively working with the provider to resolve the bottleneck, and we will share further updates as soon as they are available.